Nintex eSign - Get a signed document

Use the Nintex eSign - Get a signed document action A tool for building the processes, logic, and direction within workflows. to retrieve a signed document.

For more information about the Nintex eSign connector, go to Nintex eSign.

Configure the Nintex eSign - Get a signed document action

  1. Add the action to the workflow and open the action configuration panel. For more information, see Add an action to the workflow.

  1. Select a Connection. If you do not have a connection, see Add a connection.
  1. Select the Account.
  2. Select the Template.
  3. Select the Document.
  4. Specify the Envelope ID.
  5. Create or select a variable for the output.

Nintex eSign - Get a signed document action fields and settings

Section

Field

Description

Variable types

(Unlabeled)

Connection Credentials and other settings required to pass data between the workflow and the indicated service, which could be a cloud service, business application, or content store.

The Nintex eSign connection to use to retrieve the signed document.

To refresh the available connections, click .

(n/a)

Account

The Nintex eSign account to send the documents from.

Text, Decimal, Integer, Boolean, DateTime, Collection
  Template

The Nintex eSign template used when the documents were signed.

Text, Decimal, Integer, Boolean, DateTime, Collection
  Document

The name of the document that has been signed.

If you used a variable for the document name in the originating Nintex eSign - Get a signature action input, use that same variable here.

Text, Decimal, Integer, Boolean, DateTime, Collection
  Envelope ID

The unique identifier of the Nintex eSign envelope that contains the signed document.

Text, Decimal, Integer, Boolean, DateTime, Collection
  Download password

The password associated with the document.

Text, Decimal, Integer, Boolean, DateTime, Collection
Output Document

Stores the result of the action as a File variable.

Note: Your tenancy's default file storage location must be configured to hold files for later reference. This location is used for uploaded files and for files stored as output from actions.

File

Troubleshooting

If you receive an error message listed below, it may be because of one of the reasons noted. Review the action's configuration settings to resolve the errors.

Error Message

Cause

The signed document download request failed. The envelope has been deleted.
There was an error processing the signed document download request. The download password is incorrect.
The envelope ID is invalid.
The document is missing due to an incorrect template or document that was configured.
The envelope is still in progress or has not been completed.
The envelope was canceled.
The user entered an envelope ID that does not match the template used when the documents were signed.
The user is using a variable for the Document field, and the variable’s value contains an invalid document name.