Botflows unavailable after Windows update

Your botflows may not be available in Nintex RPA Central installed on Windows 10 after one or more Windows updates have been applied.

Nintex RPA Central is often installed on a Windows 10 VM and database files are stored at:

C:\Windows\System32\config\systemprofile

After you update Windows this may be moved to the following location:

c:\Windows.old\Windows\System32\config\systemprofile

Cause

There exists at least one Windows update (or method of applying Windows updates) that results in a subset of files within the Windows directory being moved to a Windows.old directory. Database files related to Nintex RPA Central too may be moved to this directory after a Windows update.

The following files will be impacted:

  • C:\Windows\System32\config\systemprofile\
    • RPACentralKeys.mdf
    • RPACentralKeys_log.ldf
    • RPACentralWeb.mdf
    • RPACentralWeb_log.ldf

Resolution

Do the following to fix the issue and connect to the localhost:

  1. Copy the 4 mdf/ldf files in C:\Windows\System32\config\systemprofile to a backup directory (e.g. copy to subdirectory ../RPAC DB {yyyy-MM-dd}/).
  2. Manually stop the SQLSERVR.exe process.
  3. Stop the Nintex RPA Central service.
  4. Stop the Nintex Bot Service or Nintex RPA Service.
  5. Copy the 4 mdf/ldf files located at C:\Windows.old\Windows\System32\config\systemprofile to the new location, replacing the 4 files that you have just backed up.
  6. Important: Ensure that you copy from the Windows.old directory to the Windows directory.

  1. Restart any services that were stopped.