Nintex Connector Workflow Queue Service failed to start

Symptom

The Nintex Connector Workflow Queue Service failed to start and the following error message appears:

"No connection could be made because the target machine actively refused it"

Cause

This message indicates a firewall issue.

Resolution

Confirm accessibility of all required ports and Nintex Connector URLs using the following procedure.

  1. If you have a firewall in place, make the following ports accessible (the ports will be used by Nintex Connector Workflow Queue Service).

    • 5671/TCP
    • 5672/TCP
    • 443/HTTP

    Note: Note: Nintex uses Advanced Message Queuing Protocol (AMQP) over TCP traffic for Service Bus brokered messaging, which requires ports 5671 and 5672 to both be open for AMQP communication. By default, port 5671 is used by Secure AMQP.

  2. Confirm that the server can access the Nintex connector URLs: From the server running the Nintex Connector Workflow Queue Service, navigate to each of the following URLs.

    • https://live.nintex.com
    • https://liveservices.nintex.com
    • https://nintexlive.blob.core.windows.net/serviceicon
    • https://nintexrelay.servicebus.windows.net/
  3. To start the service on the current server, do the following:

    1. On the Central Administration Home page, click Application Management.

    2. In the Service Applications section, click Manage services on server.

    3. Click Start for Nintex Connector Workflow Queue Service.