Nintex-SharePoint 2013
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Registration error: Nintex Live

Symptom

The following message appears when a user attempts to register with Nintex Live by clicking the SharePoint user name, selecting Nintex Mobile Apps, and then selecting Register with Nintex Live.

"An error occurred during the registration process."

Cause

This error may be caused by an inability to connect to Nintex Live.

Resolution

Make sure that the SharePoint site can connect to Nintex Live.

To check for blocked IP addresses

  1. With the help of the network administrator, trace the connections by opening the proxy and firewall servers.

  2. Compare the traced connections to the known reserved addresses.

    See http://blogs.msdn.com/b/narahari/archive/2011/08/01/ip-range-for-windows-azure-platform-identifying-connectivity-issues.aspx; refer to Microsoft sites for the latest information on identifying connectivity issues with Windows Azure.

  3. If any IP addresses used by the service bus are blocked, then contact your network infrastructure team to resolve the situation.

To enable verbose logging for the Nintex Live Relay Service and review log files

  1. In a text editor, open the relay service configuration file.

    By default, the file is located in the SharePoint hive, under /BIN/NintexLive. For example, the default location is %ProgramFiles%\Common Files\Microsoft Shared\Web Server Extensions\15\BIN\NintexLive\Nintex.Live.RelayService.exe.config.

  2. Edit the file to include the following lines, indicated by bold type.

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
    <appSettings>
    <add key="MaximumRetryInterval" value="60" />
    <add key="RetryIntervalCoefficient" value="2.5" />
    <add key="KeepLogsForMonths" value="2" />
    <add key="VerboseFileLogging" value="true" />
    </appSettings>
    <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" />
    </startup>
    <system.net>
    <defaultProxy useDefaultCredentials="true">
    <proxy bypassonlocal="True" usesystemdefault="True"/>
    </defaultProxy>
    </system.net>
    </configuration>

  3. Save your changes and close the file.

  4. To start verbose logging, restart the Nintex Live Relay Service.

    For instructions, see the related procedure below.

  5. Retry Nintex Live registration: Click the SharePoint user name to display the context menu, select Nintex Mobile Apps, and then select Register with Nintex Live.

  6. To review the log files, open the folder /BIN/NintexLive/LOGS in the SharePoint hive.

    The default location for the Nintex Live Relay Service log files is as follows.

    %ProgramFiles%\Common Files\Microsoft Shared\Web Server Extensions\15\BIN\NintexLive\Logs

To restart the Nintex Live Relay Service

  1. On the Central Administration Home page, click System Settings and then click Manage services on this server under Servers.

  2. Click Start for Nintex Live Relay Service.