Solution package is stuck in deployment: Nintex Workflow
Symptom
The Nintex Workflow solution package (
Cause
The solution may not have been deployed correctly.
Resolution
Cancel and restart the deployment.
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Run the following stsadm command to list the job identifiers for all deployments in progress.
stsadm -o enumdeployments
For a mapping of Stsadm operations and their equivalent Windows PowerShell cmdlets, see the following Microsoft TechNet article: http://technet.microsoft.com/en-us/library/ff621081.aspx
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Note the job identifier for the stuck Nintex Workflow deployment job.
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Cancel the deployment, using the following stsadm command:
stsadm -o canceldeployment -id "your job id string here"
The solution management page in Central Administration updates the status of the solution to "not deployed." You can now deploy the solution again.
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Redeploy the solution by doing one of the following:
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Click the Deploy Solution button in the toolbar. For complete instructions, see Steps for deploying solutions.
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Run the following stsadm command:
stsadm.exe -o deploysolution -n nintexworkflowSPSE.wsp -allcontenturls -immediate -allowgacdeployment
If the deployment is stuck again, analyze the SharePoint ULS log files to determine what is causing the failure. For more information, see Review SharePoint ULS log files.
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