Request made without authorization
Issue
You run a DocGen Package and see this message:
An error has occurred: a request was made without authorization. Try again in order to authorize. (AuthInvalid)
Cause
You might get this error if the user generating documents needs to authorize the app, or the integration user needs to re-authorize the app.
Resolution
Try having the user generating documents authorize the app. If that doesn't work, revoke tokens and try having the integration user re-authorize the app. If your organization uses Connected Apps, consider relaxing IP restrictions.
For more information about the integration user, see Authorize Nintex DocGen.
Authorize the app
Note: This procedure requires the Salesforce Customize Application permission
- Click the Nintex Admin tab.
The Nintex Admin Home left navigation displays.
- On Nintex Admin, click Authorize Nintex DocGen for Salesforce.
Tip: If you want to authorize the app to run under a different account than the one you're currently using, log into the account you want the app to use and click the button again.
Revoke tokens for the app
- From your user account, click My Settings (Salesforce Classic) or Settings (Lightning).
- In the Quick Find box, type Advanced User Details then click Advanced User Details to display a list of settings for your profile.
- In OAuth Connected Apps, click Revoke for every Nintex DocGen for Salesforce token.
Relax IP restrictions
- From Setup, enter Connected Apps in the Quick Find box, then click Connected Apps to display a list of apps in your organization.
- Click Edit for Nintex DocGen.
- In IP Relaxation, select Relax IP restrictions.
- Click Save.