Invalid field-level security

Issue

You run a DocGen Package and see this message:

An error has occurred. There may be a problem with your permissions or the document package setup. (MetadataInvalid)

Cause

You could get this message if the user running the DocGen Package does not have permission to access a field referenced in the DocGen Package.

Resolution

Evaluate any fields referenced in the DocGen Package with the user running the DocGen Package. If you can't find the problem, call support.

To troubleshoot permissions issues with a DocGen Package

  1. Navigate to the App Launcher by selecting the app launcher in the upper left corner, select Nintex DocGen.
  2. Select the DocGen Packages tab.
  1. Open the DocGen Package that generated the error.
  2. Evaluate all the fields referenced by the DocGen Package.
  • Look for typos in references to fields. For example, you might have an e-signature delivery with a role name of Primary, but you may have referenced the field as primary. Change the case to resolve the error.
  • Look for broken links. For example, you might have an e-signature delivery with a secure field linked to a parent field, but that parent field links to a secure field in a different DocGen Package. Change the link from the parent field to reference the secure field in the DocGen Package that's generating the error to resolve the error.
  • Check permissions. If the DocGen Package references Salesforce fields, check that the users running the DocGen Package have access to the those fields. For example, if you found that users didn't have access to a field referenced in your DocGen Package, you could grant users access to the field, or relax restrictions to the field, or use a different field in the DocGen Package to resolve the error.
  • For information on evaluating user access, see Verify Access for a Particular Field. For information on how to manage field permissions, see What Determines Field Access? and Object Permissions.

  1. Click Save.

Contact support

Contact support to resolve this issue by either opening a ticket, sending an email, or making a call.

Ticket:

Open a support case to request service from our support team: https://www.nintex.com/resources/nintex-customer-support/

Email or phone:

Contact our global support team by email at DDPsupport@nintex.com or call a support team in your region using one of the phone numbers below:

  • Americas: +1 (425) 533-2827
  • EMEA: +44 203 695 5056
  • APAC: +6 138 820 5139

Press 2 for support and then 4 for Nintex.