Error processing a Microsoft Office file
Issue
You run a DocGen Package and see this message:
An error occurred processing a Microsoft Office file. (InternalError)
Cause
You could get this message if the app can't identify a Microsoft Office file as an attachment.
Resolution
- In Nintex DocGen for Salesforce, check the file extension of the attachment. Make sure that the file has the correct file extension according to its file type. For example, Microsoft Word files should have the .doc or .docx file extension, and Microsoft Excel files should have the .xls or .xlsx file extension.
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Try uploading the attachment to Salesforce again. This may resolve any issues related to file identification.
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Troubleshoot the template options in the DocGen Package:
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Navigate to the App Launcher and select Nintex DocGen.
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Select the DocGen Packages tab.
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Open the DocGen Package that generated the error.
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In Select Files, click Options (Gear Icon) and evaluate the advanced criteria. Make one of the templates in the package required and click Save.
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Generate documents again using the record that generated the error.
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For more information about working with attachments, see the Salesforce help topic, Attach Files to Records.
For a list of supported file types, see Supported template file types.