An error occurred downloading a file
Issue
You run a DocGen Package and see this message:
An error occurred downloading a file. (ResourceInvalid)
Cause
You could get this message if the app can't identify a file type for an attachment.
Resolution
- On the record you're using to generate documents, make sure any files attached to the Notes & Attachments related list have file extensions. (For example, Microsoft Word files would have the .doc or docx file extension and Excel files would have .xls or .xlsx.).
- If that doesn't work or if all attachments already have file extensions, then try uploading the attachment to Salesforce again.
For more information about working with attachments, see the Salesforce help topic, Attach Files to Records.
For a list of supported file types, see Supported template file types.